Any way to get P4 to run on a modern browser?

We have transitioned the forums from Xenforo to Burning Board
Try to get people who play the game involved on the boards. Money is paid to run this server, handle the domains and pay for the software that these forums run on. Please join the forums and post in appreciation.
  • Getting that P4 itch again, but unfortunately I bought a new computer with Win 10 and despite trying to fiddle with every permission in Java and every browser I can get my hands on, I'm unable to run the game. I do have an old work laptop that I haven't tried yet that I think has Capitan or Sierra. Am I out of luck until the new version?

  • I just managed to get it running on windows 10, after having that same old itch.


    What I did was to add the "play" page to my java exception url list. (and the p4 home page just in case as well)


    Then I downloaded the "IE tab" extension for google chrome. Opened p4, told the extension to open in an IE tab, and ran the game. I just had to tell java it was okay multiple times, but its running for me now.


    Good luck

  • After trying for days to get chrome/Internet Explorer/firefox to allow java applets, I just could not get any of these browsers to work. Here is what I did instead -


    Download the Pale Moon browser here. It is an open-source browser for windows and linux that still supports NPAPI plugins (java). I would recommend only using this browser for p4. Modern browsers do not support NPAPI or java plugin anymore because of security issues.


    Then go to java.com and download the latest version of java. Pale moon would not load p4 until I downloaded and installed the latest update for java.


    Hope this helps.

    Cheers


    Edit - Here are some additional steps I needed to take in order to get p4 running on my windows 10 laptop-


    Add "phantasia4.net" and "phantasia4.net/cgi-bin/p4_client.cgi" to java exception site list. (google search "configure java" if you don't know how to do this)


    Open Pale Moon Browser, press ALT to see menu bar > tools > options> content> uncheck the "block all popups box".


    Open Pale Moon Browser, press ALT to see menu bar > tools > options> security> change the "add-on security level" dropdown to off. (setting this to off is dangerous, only use this browser to play p4).


    Then close and reopen pale moon as administrator. Happy holidays!